Windows 7+

current version 54.0


PLEASE READ, if you are a v54 user looking to fix the ‘NET::ERR_CERTIFICATE_TRANSPARENCY_REQUIRED’ issue.

If you are looking for previous versions, please check out the Builds Archive

system requirements
• Windows 7+
• An Intel Pentium 4 processor or later that's SSE2 capable

Windows Installer provided by Advanced Installer


If this is not your Operating System or if you are looking for a different platform please choose from the following


Currently IridiumBrowser is available for the following Operating Systems
Windows 7+ • Mac OS X 10.9+ • Ubuntu 14.04+ (64-bit) • Debian 8+ (64-bit) • Mint 17+ (64-bit) • openSUSE 13.1+ • Leap 42.1+ • Tumbleweed
IridiumBrowser is not available for Android, iOS, Windows Mobile or any other mobile OS!