Repositories for openSUSE

current version 2018.4
(based on Chromium 66.0.3359.130)

Leap 15.0

zypper ar https://downloads.iridiumbrowser.de/openSUSE_Leap_15.0/ iridium
zypper in iridium-browser

Leap 42.3

zypper ar https://downloads.iridiumbrowser.de/openSUSE_Leap_42.3/ iridium
zypper in iridium-browser


System requirements:
• openSUSE Leap 42.3+
• An Intel Pentium 4 processor or later that’s SSE2 capable